Back to all reports

Alleyway street light not working

Reported in the Street lighting category anonymously at 16:53, Thursday 2 March 2017

Sent to Waltham Forest Borough Council 2 minutes later

This has been reported multiple times to Waltham Forrest Council. Streetlight no. 5 in the alleyway between Whitehall Gardens and Long Deacon Rd is not working and hasn't been working since just after the new year. Despite repeated requests online and phone calls, it still isn't fixed and we are now in March. Because its an alleyway, it gets pitch black at night if one of the lights are out, which makes it feel very unsafe when returning from work.

RSS feed of updates to this problem Receive email when updates are left on this problem.

Updates

  • Took two months but thankfully, it has finally been fixed.

    State changed to: Fixed

    Posted anonymously at 12:28, Tuesday 7 March 2017

  • After one day of operation, this light is now no longer working. The Waltham Forest portal is not working properly- keep getting an error message or request bounces so I can't log the problem on their website.

    State changed to: Open

    Posted anonymously at 23:33, Thursday 9 March 2017

  • Have now managed to log this complaint using online portal

    Posted anonymously at 09:36, Friday 10 March 2017

Provide an update

Please note that updates are not sent to the council. Your information will only be used in accordance with our privacy policy

Now to submit your update…

Do you have a FixMyStreet password?

Yes I have a password

Forgotten your password? Confirm by email instead, providing a new password at that point. When you confirm, your password will be updated.

No Let me confirm my update by email

Providing a password is optional, but doing so will allow you to more easily report problems, leave updates and manage your reports.