Back to all reports

Street light (number 17) has twice been reported by myself as not working. Waltham Forest Council sent me an auto response stating that the problem would be fixed within ten working days. This has not happened.

Reported in the Street lighting category anonymously at 20:03, Sun 20 November 2016

Sent to Waltham Forest Borough Council 2 minutes later

I have twice reported the above mentioned street light as not working - along with an adjacent light column on the nearby traffic island. Despite being told that repairs would take place within ten days this has not happened - for either of the occasion that I have reported the problem on. The street light is on King's Road (Chingford, London E4) and is close to the entrance to the recycling centre.

RSS feed of updates to this problem Receive email when updates are left on this problem.

Updates

  • Still open, via questionnaire, 08:58, Mon 19 December 2016

  • I can advise further if and when the problem is rectified (i.e. the streetlight is repaired). I have taken this matter up with three local councillors - all of whom have failed to even acknowledge my email to them!

    Posted anonymously at 08:58, Mon 19 December 2016

  • Questionnaire filled in by problem reporter

    Posted anonymously at 09:52, Monday 16 January 2017, marked as fixed

Provide an update

Please note that updates are not sent to the council. Your information will only be used in accordance with our privacy policy

Now to submit your update…

Do you have a FixMyStreet password?

Yes I have a password

Forgotten your password? Confirm by email instead, providing a new password at that point. When you confirm, your password will be updated.

No Let me confirm my update by email

Providing a password is optional, but doing so will allow you to more easily report problems, leave updates and manage your reports.