You can move around with your keyboard
plus
minus
left
right
Drop pin on the map to start a new report
space
Press space again to adjust the location
space
Start new report here Reposition report here
Back to all reports

Display failed

Reported via desktop in the Bus stops category anonymously at 09:43, Mon 13 November 2023

Sent to Luton Borough Council less than a minute later. FixMyStreet ref: 5203931.

Bus departure display has not been working for the last month.

RSS feed of updates to this problem Receive email when updates are left on this problem.

Updates

  • It wasn't fixed last week, haven't had the opportunity to check since then.

    Posted anonymously at 10:52, Mon 11 December 2023
    Still open, via questionnaire

  • I think this ought to be done more urgently. A bit of fairing on the post is missing exposing the cables which presumably are what powers the display at the top. Rain can get in, so it's not surprising the display is not working. But having exposed wiring is, I'd have thought, a safety issue. So a bit concerning that nothing has been done in 2 months.

    Posted anonymously at 11:15, Monday 8 January 2024
    Still open, via questionnaire

  • Still open, via questionnaire, 12:49, Monday 5 February 2024

  • Still open, via questionnaire, 16:46, Monday 4 March 2024

  • Still open, via questionnaire, 17:30, Monday 1 April 2024

  • Not fixed but I had an email from a Council official saying that they are aware of the problem.

    Posted anonymously at 18:03, Monday 29 April 2024
    Still open, via questionnaire

  • I got an email from the Council saying they were going to fix it but no timescale.

    Posted anonymously at 20:07, Monday 27 May 2024

Provide an update

Please note that updates are not sent to the council. Your information will only be used in accordance with our privacy policy

Next: Tell us about you

Your update

Tell us about you

Do you have a FixMyStreet password?